Process quota exceeded when using PIPE

Post Reply

Topic author
peter
Newbie
Posts: 3
Joined: Mon Jan 13, 2020 2:25 am
Reputation: 0
Status: Offline

Process quota exceeded when using PIPE

Post by peter » Mon Jan 13, 2020 2:34 am

Hi,

I tried to redirect command output to a file but got an error.
The command is shown below:

Code: Select all

$ PIPE vgit clone "https://Peter:password@bitbucket.org/vms_software/ossvms.git" > tmp.txt
The content of tmp.txt file is shown below:

[i]Cloning into 'ossvms'...
%TYPE-F-WRITEERR, error writing SYS$OUTPUT:.;
-RMS-F-SYS, QIO system service request failed
-SYSTEM-F-EXQUOTA, process quota exceeded[/i]


Could anybody help me to redirect the command output, please?
Last edited by marty.stu on Mon Jan 13, 2020 3:21 am, edited 2 times in total.


cmkrnl
Visitor
Posts: 1
Joined: Mon Jan 13, 2020 2:55 am
Reputation: 0
Status: Offline

Re: Process quota exceeded when using PIPE

Post by cmkrnl » Mon Jan 13, 2020 3:05 am

You should be able to achieve the same behaviour, without exceeding any process quotas by executing this command first:

Code: Select all

$ DEFINE/USER SYS$OUTPUT TMP.TXT
This will create a user mode logical that will exist for the run-time of the VGIT program, temporarily redirecting the output stream to the file TMP.TXT.

As for your EXQUOTA error, there is likely some process quota that will need increasing for you to use PIPE. You could use the following command to examine your quotas to determine which is low:

Code: Select all

$ SHOW PROCESS/QUOTA
I would start by looking at the I/O limits.

Regards, Tim.


Topic author
peter
Newbie
Posts: 3
Joined: Mon Jan 13, 2020 2:25 am
Reputation: 0
Status: Offline

Re: Process quota exceeded when using PIPE

Post by peter » Tue Jan 14, 2020 1:42 am

Tim,
thank you for your help. The first method helped me to resolve this issue.
We also tried to examine the quotas of my process. All quotas were enough for vgit operation. We even increased quotas significantly, but the error still occurs.

Regards,
Peter


brett.cameron
VSI Expert
Contributor
Posts: 10
Joined: Mon Jun 24, 2019 9:51 am
Reputation: 0
Status: Offline

Re: Process quota exceeded when using PIPE

Post by brett.cameron » Tue Jan 14, 2020 3:46 am

Defining DECC$STREAM_PIPE ($ define DECC$STREAM_PIPE true) will also work. The problem is that vgit is continuously updating the terminal with a progress counter as it is cloning the repo (using printf()'s with a \r as opposed to a \n). This works fine for the terminal but blows the mailbox being used by pipe. Defining the aforementioned logical name gets around this but you end up with all of the progress updates written to the file in a big messy splodge. We'll see about adding a "quiet" option to vgit that doesn't do the progress updates.


Topic author
peter
Newbie
Posts: 3
Joined: Mon Jan 13, 2020 2:25 am
Reputation: 0
Status: Offline

Re: Process quota exceeded when using PIPE

Post by peter » Wed Jan 15, 2020 4:53 am

Hello Brett,

I tried to define "DECC$STREAM_PIPE", but it did not help to solve this issue.
A "quiet" option in vgit works fine.

Regards,
Peter


brett.cameron
VSI Expert
Contributor
Posts: 10
Joined: Mon Jun 24, 2019 9:51 am
Reputation: 0
Status: Offline

Re: Process quota exceeded when using PIPE

Post by brett.cameron » Wed Jan 15, 2020 4:58 am

Interesting. Possibly there's something different in my environment, or possibly scale is a factor (I cloned a relatively small repo). Anyway, the "quiet" option should not be too far away :)

Post Reply