Apache Level Web Page Authentication

Having difficulties when installing the system? Your system runs slowly and requires some tweaking? You can get help here
Post Reply
User avatar

Topic author
jeetu.singh
Newbie
Posts: 3
Joined: Fri Jun 28, 2019 6:12 am
Reputation: 0
Status: Offline

Apache Level Web Page Authentication

Post by jeetu.singh » Tue Dec 24, 2019 3:31 am

Hello there,

I have SYSUAF level authentication enabled for Webpage but I want apache level authentication to webpage.
I have "VSI AXPVMS CSWS V2.4-38C" installed on system.
Any suggestion would be helpful. Thank you in advance.


brett.cameron
VSI Expert
Contributor
Posts: 10
Joined: Mon Jun 24, 2019 9:51 am
Reputation: 0
Status: Offline

Re: Apache Level Web Page Authentication

Post by brett.cameron » Tue Dec 24, 2019 3:38 am

From the release notes:

Changes to OpenVMS SYSUAF-based authentication module

The authentication and authorization model used by Apache HTTP Server version 2.4 differs from that of previous versions. In version 2.4 it is necessary to register the specific authentication (or authorization) provider that you wish to use for a particular directory or location. In this way it is possible to configure and use different providers with different directories or locations.

The following example illustrates use of the OpenVMS authentication provider for the “/test” directory:

<Directory /test>
Options FollowSymLinks
AllowOverride AuthConfig
AuthType Basic
AuthName "OpenVMS authentication"
AuthBasicProvider OpenVMS
require valid-user
</Directory>

We have specified an AuthBasicProvider of “OpenVMS” (note that the name of the provider is case-sensitive). This causes the authentication infrastructure to use the OpenVMS password checking module (included in mod_authnz_openvms.exe).

Note that in order for this to work correctly the following modules must be loaded::

– mod_authn_core.exe
– mod_authz_core.exe
– mod_auth_basic.exe
– mod_authnz_openvms.exe

The mod_authz_core.exe module is strictly only required for authorization (as opposed to authentication), but since mod_authnz_openvms.exe includes functionality to handle both authentication and authorisation, it is recommended to load mod_authz_core.exe whenever using the mod_authnz_openvms.exe module.

It should also be noted that the OpenVMS authentication and authorization module now accepts no configuration commands (as a consequence of the changes in 2.4 to the how authentication and authorization are handled such commands are now superfluous). Specifically, the following directives have been removed:

– AuthOpenVMSUser
– AuthOpenVMSGroup

User avatar

Topic author
jeetu.singh
Newbie
Posts: 3
Joined: Fri Jun 28, 2019 6:12 am
Reputation: 0
Status: Offline

Re: Apache Level Web Page Authentication

Post by jeetu.singh » Tue Dec 24, 2019 8:18 am

Hello Brett,
Thank you for input.
As I stated in my Post. We already have SYSUAF based authentication enabled with same configuration in HTTTPD.CONF file which you have shared.
My requirement is : I want web page access via credentials created by apache utility like htpsswd or htdigest.
Any help for the same would be appreciated.
for example :

https://httpd.apache.org/docs/2.4/mod/m ... icprovider
https://httpd.apache.org/docs/2.4/mod/m ... _file.html

tried those option but didn't work.


brett.cameron
VSI Expert
Contributor
Posts: 10
Joined: Mon Jun 24, 2019 9:51 am
Reputation: 0
Status: Offline

Re: Apache Level Web Page Authentication

Post by brett.cameron » Tue Dec 24, 2019 9:30 am

HTDIGEST.EXE and HTPASSWD.EXE are provided (in apache$root:[bin]); however these work as per other platforms and do not have any hooks into SYSUAF.

User avatar

Topic author
jeetu.singh
Newbie
Posts: 3
Joined: Fri Jun 28, 2019 6:12 am
Reputation: 0
Status: Offline

Re: Apache Level Web Page Authentication

Post by jeetu.singh » Tue Dec 24, 2019 9:41 am

yeah. I created credentials file and enabled these options but NO success. Web page prompting for credentials but unable to login.
did you try those option ? if yes, Please let me know configuration/module option to make it work.
Looking forward your suggestion. thank you in advance.

Post Reply