Synchronization - Upload Issue

Here you can discuss the universal Integrated Development Environment for OpenVMS
Post Reply

Topic author
brianreiter
Contributor
Posts: 18
Joined: Fri Jun 14, 2019 4:17 pm
Reputation: 0
Status: Offline

Synchronization - Upload Issue

Post by brianreiter » Wed Sep 11, 2019 8:34 am

Hi Folks,

I've reverted to VMS-IDE 1.0.2 until I can persuade IT to add more memory to my laptop. In the meantime I've been seeing issues with the upload side of synchronization. Downloads appear to be fine, but any uploads are reported as being successful but the file are not showing in the source directory under VMS.

Is there a way of tracing what the extension is doing? I can't move to the newer versions, the extension host keeps crashing out with heap errors.

cheers

Brian


sergey_vorfolomeev
VSI Expert
Contributor
Posts: 20
Joined: Thu Aug 22, 2019 12:17 am
Reputation: 0
Status: Offline

Re: Synchronization - Upload Issue

Post by sergey_vorfolomeev » Fri Sep 13, 2019 5:06 am

1. check SSH settings
2. check source, headers, builders mask for errors (for example - missing enclosing curly bracket)


Topic author
brianreiter
Contributor
Posts: 18
Joined: Fri Jun 14, 2019 4:17 pm
Reputation: 0
Status: Offline

Re: Synchronization - Upload Issue

Post by brianreiter » Fri Sep 13, 2019 8:09 am

As far as I can tell the SSH configuration appears to be fine. Amending the file on the server and the electing to synchronize does result in the correct file being downloaded.

I can't see any issues with the builders, headers or source parameters.



cheers

Brian


sergey_vorfolomeev
VSI Expert
Contributor
Posts: 20
Joined: Thu Aug 22, 2019 12:17 am
Reputation: 0
Status: Offline

Re: Synchronization - Upload Issue

Post by sergey_vorfolomeev » Tue Sep 17, 2019 8:24 am

If it will help, configure debug output -
debug-output-to.png
Open file and analyze it. For example, this we can see four files are selected for upload and successfully uploaded.
log_example.png


Topic author
brianreiter
Contributor
Posts: 18
Joined: Fri Jun 14, 2019 4:17 pm
Reputation: 0
Status: Offline

Re: Synchronization - Upload Issue

Post by brianreiter » Tue Sep 17, 2019 9:11 am

Ah now that helps a lot:

Code: Select all

sftp ready
writestream created for build/mis/v01_02_01_01/source/mis_jt_test.pas
write stream error: syserr: no such file or directory, or no privilege for attempted operation, file: build/mis/v01_02_01_01/source/mis_jt_test.pas
dest error syserr: no such file or directory, or no privilege for attempted operation, file: build/mis/v01_02_01_01/source/mis_jt_test.pas
source error syserr: no such file or directory, or no privilege for attempted operation, file: build/mis/v01_02_01_01/source/mis_jt_test.pas
done false
Quick uploading:  false
Which is odd seeing as VS Code was able to to download the file without any issue. As far as I can see the file name and directory structure exist and the owner has RWED access to the files.

Code: Select all

$ dir [.build.mis.v01_02_01_01.source]mis_jt_test.pas/sec

Directory HATMS$USER:[REITER.BUILD.MIS.V01_02_01_01.SOURCE]

mis_jt_test.pas;128
                     [HATMS,REITER]                   (RWED,RWED,RE,)

Total of 1 file.[code]

Other SFTP accesses seem to work OK.


sergey_vorfolomeev
VSI Expert
Contributor
Posts: 20
Joined: Thu Aug 22, 2019 12:17 am
Reputation: 0
Status: Offline

Re: Synchronization - Upload Issue

Post by sergey_vorfolomeev » Wed Sep 18, 2019 2:43 am

maybe it's because of case sensitivity. the directories in VMS must be the same as in PC.
try adding to LOGIN.COM
$ set process/parse_style=extended


Topic author
brianreiter
Contributor
Posts: 18
Joined: Fri Jun 14, 2019 4:17 pm
Reputation: 0
Status: Offline

Re: Synchronization - Upload Issue

Post by brianreiter » Wed Sep 18, 2019 9:17 am

OK, looks like setting the /PARSE=EXTEND made no difference, nor did upper casing the directory path, however shortening the directory path did.

Changing "build/mis/v01_02_01_01/source" to "MIS" allowed the upload to work. I haven't set the path to "mis" yet, will try that a bit later.

Code: Select all

sftp ready
module.exports.t.SftpClient.createWriteStream (c:\Users\reiterb\.vscode\extensions\vmssoftwareinc.vms-ide-1.0.2\out\index.js:619:473399)
writestream created for MIS/mis_cli_plc.pas
Y.module.exports.t.PipeFile.u.once (c:\Users\reiterb\.vscode\extensions\vmssoftwareinc.vms-ide-1.0.2\out\index.js:619:471652)
dest finished
Object.module.exports.t.PipeFile (c:\Users\reiterb\.vscode\extensions\vmssoftwareinc.vms-ide-1.0.2\out\index.js:619:471717)
done true
E.quickSync (c:\Users\reiterb\.vscode\extensions\vmssoftwareinc.vms-ide-1.0.2\out\index.js:124:38500)
Quick uploading:  true
E.dispose (c:\Users\reiterb\.vscode\extensions\vmssoftwareinc.vms-ide-1.0.2\out\index.js:124:35368)
Disposing sources
P.dispose (c:\Users\reiterb\.vscode\extensions\vmssoftwareinc.vms-ide-1.0.2\out\index.js:431:1933)
Disposing sources
So is there something odd with the path "build/mis/v01_02_01_01/source"? VS code can download from "build/mis/v01_02_01_01" (or the all uppercase version) but not upload to it.

cheers


Brian
Last edited by brianreiter on Wed Sep 18, 2019 9:32 am, edited 2 times in total.

Post Reply