Fix for: Unable to synchronize / upload / rebuild

Here you can discuss the universal Integrated Development Environment for OpenVMS.
Post Reply

Topic author
Posts: 21
Joined: Sat Apr 22, 2023 3:56 am
Reputation: 0
Status: Offline

Fix for: Unable to synchronize / upload / rebuild

Post by gdwnldsksc » Thu May 04, 2023 9:56 am

Okay, so I wrote up this post and managed to resolve the issue myself, but i'll post it anyway so people can find the issue and (potential) resolution

..... my password had expired, and I hadn't realized it since my SSH sessions from yesterday were still open and logged in. A new SSH session promptly informed me of that, and changing my password from the prompts made everything happy again.

Possible enhancement suggestion for VMS-IDE: Detect this condition somehow? Since SSH authentication with expired password is still initially successful - post-auth is when it forced PW change......


Worked yesterday, today I receive two different error messages - one system received updates and installed VS2022 new, the other is unmodified with no changes to config, source code, or base system.


Cannot find files on remote source
Synchronization failed.

Rebuild project:
TypeError: Cannot read properties of undefined (reading 'unpipe')
Build failed.

From another thread with the same/similar issue, I attempted the fix they had found working there to set skipSignatureVerification to 'true', and that did not help either.

No changes were performed on the remote E9.2-1 system, no changes to the ssh-helper settings or synchronizer-settings, and the remote directories all are still the same (no changes to those since last successful sync/build either).

Post Reply