sftp image xfer of vms saveset fails

OpenVMS x86 Field Test questions, reports, and feedback.
Post Reply

Topic author
kaycee
Visitor
Posts: 2
Joined: Wed Jan 04, 2023 3:22 pm
Reputation: 0
Status: Offline

sftp image xfer of vms saveset fails

Post by kaycee » Wed Jan 04, 2023 3:35 pm

VMS v9.2, tcpip x6.0-16, openssh v8.9-1B, ssl1112 v1.1-1N
sftp> image or binary
Invalid command
sftp> get file.a ! vms saveset from VSI itanium v8.4-2L1 TCPIP v5.7-13ECO5F
i hoped with no image/binary command the 9.2 port would auto-recognize the file from another vms system.
I could not find if their is a -flag for image
some tries it stack dumps, sometimes it finishes xfer 100%, but the file is not a vms saveset.

any pointers and help on what I am missing?


tim.stegner
VSI Expert
Active Contributor
Posts: 28
Joined: Wed Jul 21, 2021 9:14 am
Reputation: 0
Status: Offline

Re: sftp image xfer of vms saveset fails

Post by tim.stegner » Wed Jan 04, 2023 3:45 pm

OpenSSH does not understand VMS file structures; it transfers everything in Stream-LF.

In order to transfer a save-set, ZIP is recommended. There's a set of ZIP/UNZIP files in subdirectory of SYS$ETC as of V92.

-tym


sms
Valued Contributor
Posts: 87
Joined: Fri Aug 21, 2020 5:18 pm
Reputation: 0
Status: Offline

Re: sftp image xfer of vms saveset fails

Post by sms » Wed Jan 04, 2023 6:01 pm

Code: Select all

> [...] but the file is not a vms saveset.

   As usual, showing the actual command and the actual error message
might be more helpful than a vague description/interpretation. 
Copy+paste is your friend.

> In order to transfer a save-set, ZIP is recommended. [...]

   Or, if the only problem at the destination is bad file attributes,
then it should be possible to fix them.  See, for example:

      http://antinode.info/dec/sw/fixrec.html


Topic author
kaycee
Visitor
Posts: 2
Joined: Wed Jan 04, 2023 3:22 pm
Reputation: 0
Status: Offline

Re: sftp image xfer of vms saveset fails

Post by kaycee » Thu Jan 05, 2023 11:14 am

the command was as i listed
sftp> get file.a
sometimes it stack dumps, sometimes it get 100% but was not a valid saveset after xfer.

i put files into zip format and it works, just an extra step. Thanks for the help.


sms
Valued Contributor
Posts: 87
Joined: Fri Aug 21, 2020 5:18 pm
Reputation: 0
Status: Offline

Re: sftp image xfer of vms saveset fails

Post by sms » Thu Jan 05, 2023 11:47 am

Code: Select all

> the command was as i listed [...]

   I'd bet that the error message was more elaborate.

> i put files into zip format and it works, just an extra step. [...]

   At each end.

   Zip ("-V") + UnZip should work, but it requires more storage space at
each end (at least for a while), and more CPU time.  Setting the file
attributes is simpler/faster, unless your file-transfer scheme actually
changes the data (like an ASCII FTP transfer, for example).

   But, it's your storage and your time.

Post Reply