Is the Python v3.8.2 for VSI-VMS-8.4-1H1 usable with the HP-VMS-8.4 ?


Topic author
l.cedric
Active Contributor
Posts: 35
Joined: Thu Jul 18, 2019 8:18 am
Reputation: 0
Status: Offline

Is the Python v3.8.2 for VSI-VMS-8.4-1H1 usable with the HP-VMS-8.4 ?

Post by l.cedric » Fri Mar 12, 2021 9:46 am

Hello,

Does anyone knows it or tried this VSI Python v3.8.2 on a HP-VMS-8.4 ?
Of course, i've seen on its page the requirement : VSI-VMS-8.4-1H1 I64 or higher (so very close to our HP-VMS version)
As our servers are not yet all migrated to the new VSI-VMS, if possible :
1) I'd prefered to use-support 1 version of Python instead of 2 on our environments (~ 45 servers, which began to migrate to the VSI-VMS)
2) And I'd prefered to use the last version 3.8.2 (otherwise the only one suitable officialy for HP-VMS-8.4 is this v2.7.18)

Remark / context :
- It's for a POC (Proof of Concept) to show if ANSIBLE (which needs Pyhton) is interoperable with VMS (HP and VSI)
- ANSIBLE = a DevOps tools which allows Contineous Deployment, and is recommended by our Architects (and already used-bought in our company)

Thanks in advance

User avatar

arne_v
Active Contributor
Posts: 37
Joined: Fri Apr 17, 2020 7:31 pm
Reputation: 0
Location: Rhode Island, USA
Status: Offline
Contact:

Re: Is the Python v3.8.2 for VSI-VMS-8.4-1H1 usable with the HP-VMS-8.4 ?

Post by arne_v » Fri Mar 12, 2021 10:37 am

Very likely the installer will complain.

If company policies allows it you could try JFP's Python kit. No installer to complain. :-)

Added in 47 seconds:
http://downloads.vmspython.org/anonymou ... images_ld/
Arne
arne@vajhoej.dk
VMS user since 1986


Topic author
l.cedric
Active Contributor
Posts: 35
Joined: Thu Jul 18, 2019 8:18 am
Reputation: 0
Status: Offline

Re: Is the Python v3.8.2 for VSI-VMS-8.4-1H1 usable with the HP-VMS-8.4 ?

Post by l.cedric » Mon Mar 15, 2021 4:30 am

/ "try JFP's Python kit" & your url :
I've already seen this JFP's Python kit for the v2.7.18 (jfppy1400i_2718.zip) i've mentioned => the officially supported for our HP-VMS-84 servers.
But none v3.8.2 (?), just another one which seems to be a v3.1 (jfppy3100i_3100.zip) ?

Regards


rjanez
Visitor
Posts: 2
Joined: Wed Jan 08, 2020 2:45 am
Reputation: 0
Status: Offline

Re: Is the Python v3.8.2 for VSI-VMS-8.4-1H1 usable with the HP-VMS-8.4 ?

Post by rjanez » Mon Mar 15, 2021 6:10 am

Hello,
The version 3100 stands for 3.10.0 alpha 6. It's a future verision of Python.

Here you can find the details and sources:
https://foss.vmsgenerations.org/openvms/python/cpython

Best regads
rjanez


Topic author
l.cedric
Active Contributor
Posts: 35
Joined: Thu Jul 18, 2019 8:18 am
Reputation: 0
Status: Offline

Re: Is the Python v3.8.2 for VSI-VMS-8.4-1H1 usable with the HP-VMS-8.4 ?

Post by l.cedric » Mon Mar 15, 2021 6:50 am

Thanks Arne & Rjanez, i've get it :)
According to your informations, I have the choice, on ours HP-VMS-8.4 servers, to try either the stable one 2.7.18 or this 3.10 Alpha ... :? (so neverthelesss > 3.8.2)
As it's for a POC, it worth a try !
Regards

User avatar

arne_v
Active Contributor
Posts: 37
Joined: Fri Apr 17, 2020 7:31 pm
Reputation: 0
Location: Rhode Island, USA
Status: Offline
Contact:

Re: Is the Python v3.8.2 for VSI-VMS-8.4-1H1 usable with the HP-VMS-8.4 ?

Post by arne_v » Mon Mar 15, 2021 3:17 pm

Give that 3.10 a try is probably the easiest.

If you really need 3.8 then download the source and build yourself. I suspect that would be a lot of work.
Arne
arne@vajhoej.dk
VMS user since 1986


Topic author
l.cedric
Active Contributor
Posts: 35
Joined: Thu Jul 18, 2019 8:18 am
Reputation: 0
Status: Offline

Re: Is the Python v3.8.2 for VSI-VMS-8.4-1H1 usable with the HP-VMS-8.4 ?

Post by l.cedric » Fri Mar 19, 2021 7:05 am

So I just gave a try to this 3.10, but ... :
  1. I tried to adapt this installation guide made for the 2.7.18 (the "Process installation")

    Code: Select all

    $ dir
    Directory DISK$SYSTEM:[VMS$COMMON.MGT.RESO.PYTHON]
    JFPLIB0020I.DSK;1   JFPPY3100I_A5P.DSK;1
    
    $ @SYS$STARTUP:LD$STARTUP.COM    
    $ ld version
    %LD-I-VERSION, LD version V8.2, module X-8 built on Mar 30 2010 16:56:37
    -LD-I-DRIVERVERSION, Driver version: 30-MAR-2010 19:48:39.74
    -LD-I-SYSINFO, Node: MANCED::, Hardware: HP rx2660  (1.67GHz/9.0MB), VMS version: V8.4
    
    $ ld connect jfplib0020i.dsk lda1:
    $ mount lda1: jfplib0020i
    %MOUNT-I-MOUNTED, JFPLIB0020I mounted on _$1$LDA1: (MANCED)
    
    $ ld connect JFPPY3100I_A5P.DSK lda2:
    $ mount lda2: JFPPY3100I    ! Without "_A5P"
    %MOUNT-I-MOUNTED, JFPPY3100I mounted on _$1$LDA2: (MANCED)
         
    $ dir lda2:[000000...]*.com
    Directory LDA2:[000000]
    compile_all.com;58
    ...
    Directory LDA2:[python3100.vms]
    logicals.com;1      python_compiler_options.com;1           setup.com;5
    
    ! No python_logicals.com as for the v2.7.18, so I've tried
    $ @lda2:[000000.python3100.vms]logicals.com
    
    ! Here, I was surprised to not have a binary distribution and have to build the whole
    $ @lda2:[000000]compile_all
    %DCL-W-ACTIMAGE, error activating image OSSL$LIBCRYPTO0101_SHR
    -CLI-E-IMAGEFNF, image file not found DSA2:[EXPLOIT.EXE]OSSL$LIBCRYPTO0101_SHR.EXE;
    
  2. So, I dig a little and indeed, on our server, no OpenSSL just :

    Code: Select all

    $ dir sys$share:*ssl$*.exe/col=1
    Directory SYS$COMMON:[SYSLIB]
    SSL$LIBCRYPTO_SHR.EXE;1
    SSL$LIBCRYPTO_SHR32.EXE;1
    SSL$LIBSSL_SHR.EXE;1
    SSL$LIBSSL_SHR32.EXE;1
    
    $ sh lo *OSSL$LIB*
    %SHOW-S-NOTRAN, no translation for logical name *OSSL$LIB*
    
    $ product show product *ssl*
                     HP I64VMS SSL V1.4-502
    
  3. And to see if I need another stuffs :

    Code: Select all

    $ analyze/image lda2:[python3100.Lib]python3shr.exe
    	…
    	Shareable Image List
            	LIBZ_SHR32     
            	
            	OSSL$LIBSSL0101_SHR   
    		OSSL$LIBCRYPTO0101_SHR
    
    	        CMA$TIS_SHR
    	        DECC$SHR
    	        LIBRTL
    	        DPML$SHR
    	        LIBOTS
    	        PTHREAD$RTL
    	        SMGSHR
                    SYS$PUBLIC_VECTORS	
    
  4. So, I checked these shareables in our sys$share and I found the last 8, but :
    • I found just this LIBZSHR32-1_2_3.EXE : doubtless I could use a $ define LIBZ_SHR32 LIBZ:libzshr32-1_2_3.exe :?:
    • And I need, at least, an OpenSSL 1.0.1 :?: Does it exist a binary distribution (PCSI package) or I have to build it too :?: :?

To resume the whole and try to find the easiest way to install a Python on our HP-VMS-8.4, known that we have already a contract with VSI :
  • Could VSI give us a Python binary distribution (PCSI package) for our HP-VMS-8.4 :?: (as it does for a VSI-VMS)
  • If not, does it exist binary distributions (Python & so an OpenSSL compatible) somewhere ?
  • If not, I have to build the whole by myself ? :cry: :cry:
(Remark : I'm not a system manager nor work on any VMS Open Source ports, so all these stuffs are new to me ... but i could learn a little ;))
Best regards


Topic author
l.cedric
Active Contributor
Posts: 35
Joined: Thu Jul 18, 2019 8:18 am
Reputation: 0
Status: Offline

Re: Is the Python v3.8.2 for VSI-VMS-8.4-1H1 usable with the HP-VMS-8.4 ?

Post by l.cedric » Mon Mar 29, 2021 9:41 am

Just to share with the community, i've just received this answer from VSI :
From the PCSI Product Description File, Python will not refuse to be installed on HPE V8.4:

Code: Select all

product VSI I64VMS PYTHON B3.8-2 full ;

execute preconfigure "@pcsi$source:[python]python$pcsi_preconfigure.com" uses [PYTHON]PYTHON$PCSI_PRECONFIGURE.COM ;
    if ((not <software VSI I64VMS VMS version minimum V8.4>) and (not <software HP I64VMS VMS version minimum V8.4>)) ;
        error NO_MIN_VMS abort ;
However, VSI has not tested it and does not support it on HPE versions.


Topic author
l.cedric
Active Contributor
Posts: 35
Joined: Thu Jul 18, 2019 8:18 am
Reputation: 0
Status: Offline

Re: Is the Python v3.8.2 for VSI-VMS-8.4-1H1 usable with the HP-VMS-8.4 ?

Post by l.cedric » Tue Apr 06, 2021 10:14 am

2 others stuffs to share with the community / my context explained in the 1st post :
  • How I succeded to connect to an OpenVMS server from Ansible on a Linux server
  • And another answer just received from VSI : "VSI has begun the port of ANSIBLE for OpenVMS. On track but no date announced yet"
Last edited by l.cedric on Tue Apr 06, 2021 10:16 am, edited 1 time in total.

User avatar

arne_v
Active Contributor
Posts: 37
Joined: Fri Apr 17, 2020 7:31 pm
Reputation: 0
Location: Rhode Island, USA
Status: Offline
Contact:

Re: Is the Python v3.8.2 for VSI-VMS-8.4-1H1 usable with the HP-VMS-8.4 ?

Post by arne_v » Sun Apr 11, 2021 9:14 pm

Regarding Python and OpenSSL I have gotten it working by using the OpenSSL in the Python image.

$ @disk1:[net.jfp.libbz2]startup.com
$ @disk1:[net.jfp.libz]startup.com
$ @disk1:[net.jfp.sqlite3]startup.com
$ @disk1:[net.jfp.openssl111g.openssl-install.sys$startup]openssl_startup0101.com "/system"
$ @disk1:[net.jfp.python2718.vms]startup.com
Arne
arne@vajhoej.dk
VMS user since 1986

Post Reply