Looking for manuals for SA5300A

Management of storage subsystems: SAN, volume shadowing, logical disks, file systems, and more.
Post Reply

Topic author
willemgrooters
Valued Contributor
Posts: 73
Joined: Fri Jul 12, 2019 1:59 pm
Reputation: 0
Location: Netherlands
Status: Offline
Contact:

Looking for manuals for SA5300A

Post by willemgrooters » Mon Jan 24, 2022 7:27 am

I have been looking for manuals on SmartArray 5300A controller, the only thing I have found using Google is the release notes - though the site claims "user manual", My system is DS10, SRM version 7.2-1, the controller is recognized, and the disks seem to be attached (I tested the SCSI cable and that is Ok).

Willem


sms
Active Contributor
Posts: 49
Joined: Fri Aug 21, 2020 5:18 pm
Reputation: 0
Status: Offline

Re: Looking for manuals for SA5300A

Post by sms » Mon Jan 24, 2022 4:56 pm

Code: Select all

> [...] the only thing I have found using Google [...]

   Thanks for the helpful link.  My search might have found more:
   
      ftp://ftp.hp.com/pub/alphaserver/storage/controllers/sa5300a/

> [...] though the site claims [...]

   Thanks for those details on "the site".

> [...] the controller is recognized, and the disks seem to be attached
> [...]

   With my weak psychic powers, I can't guess what that means, either.  
As usual, showing actual actions (commands) with their actual results
(error messages, LED indicators, ...) can be more helpful than vague
descriptions or interpretations.  Copy+paste is your friend.  Some of
your readers can't see what you're doing or what you see.


Topic author
willemgrooters
Valued Contributor
Posts: 73
Joined: Fri Jul 12, 2019 1:59 pm
Reputation: 0
Location: Netherlands
Status: Offline
Contact:

Re: Looking for manuals for SA5300A

Post by willemgrooters » Tue Jan 25, 2022 1:31 pm

OK, 'SMS':

Site I accessed was www.manualsdir.com :)

To complete the story:

I have two SCSI cards in he machine; one serves the local disk (containing HP VMS 8.2), the other connects to HZ50 (externally), normally used system disk is on that storage. Not connected at this moment.

Added two 300Gb disks, connected them to the first SCSI controller with their own U320 cable, in stead of local disk. After power on, both disks were shown in SHO DEV D (DKA0 and DKA100)

Added SA5300, connected the new disks to port 1, restore connection of local disk to it's controller. On power on, SA5300 is shown as PYA0, but no disks. SA5300 is NOT accessed by SRM. Local disk shown as DKA0 (correct)

When VMS booted (from CD), I could configure the disks using MSA$UTIL, RAID 1, 4 logical disks. Each of them initialized, BACKUP/IMA of internal disk (HP VMS 8.2) to first logical disk to get a bootable environment. It is accessible from VMS. But on restart, still SA5300 is not accessed so I cannot boot from it: I seem to miss something to be setup in console.

I accessed ftp.hp.com, found the documents but download failed for all. On second access, connection was dropped.
However, another search lead me to HPE support, found basic information on how to access the controller in SRM (https://support.hpe.com/hpesc/public/do ... 01866688-1), but links in that document are inaccessible (these are compaq.com sites, "access denied")

Willem
Last edited by willemgrooters on Tue Jan 25, 2022 1:53 pm, edited 2 times in total.


sms
Active Contributor
Posts: 49
Joined: Fri Aug 21, 2020 5:18 pm
Reputation: 0
Status: Offline

Re: Looking for manuals for SA5300A

Post by sms » Wed Jan 26, 2022 2:45 pm

Code: Select all

> I accessed ftp.hp.com, found the documents but download failed for
> all. [...]

   You seem to be ignoring all advice on how to describe a technical
problem.  See "As usual, [...]", above.  "accessed" or "failed" is not a
useful description of anything.  It does not say what you did.  it does
not say what happened when you did it.  Around here, I see no problems
fetching files from that FTP server.  For example:

ITS $ ftp ftp.hp.com
220 (vsFTPd 3.0.2)
Connected to g2t4708.austin.hp.com. 
Name (g2t4708.austin.hp.com:system): anonymous
331 Please specify the password.
Password: 
230 Login successful.
FTP> passive on
Passive is ON.
FTP> cd pub
250 Directory successfully changed.
FTP> cd alphaserver
250 Directory successfully changed.
FTP> cd storage
250 Directory successfully changed.
FTP> cd controllers
250 Directory successfully changed.
FTP> cd sa5300a
250 Directory successfully changed.
FTP> ls
227 Debuging Passive Mode (15,73,208,133,158,236).
150 Here comes the directory listing.
0291-0799-A.PDF
0292-0799-A.PDF
13JE-1000A.PDF
239449-009.PDF
ACUXE126.EXE
ACUXE_V0640_11P08_1.EXE
AV-RT16F-TE.PDF
AV-RT17D-TE.PDF
CPQACUXE13071A.TAR
EK-SA530-INE01.PDF
KZPDC288.zip
KZPDC340.zip
OVMS-ACU-XE.zip
TC020604TB.PDF
TRU64-ACU-XE.zip
acu-xe-userguide.pdf
adfu_v1_10a.zip
av-rt16b-te.pdf
av-rt16c-te.pdf
av-rt16d-te.pdf
av-rt16e-te-192268-003.pdf
av-rt17a-te.pdf
av-rt17b-te.pdf
av-rt17c-te.pdf
ek-sa530-in-b01.pdf
ek-sa530-in-c01.pdf
ek-sa530-in-d01.pdf
hp-axpvms-acuxe-v0640-11p08-1.zip
kzpdc294.bin
sa5300a_rmf2.pdf

226 Directory send OK.
557 bytes received in 00:00:00.00 seconds (181.32 Kbytes/s)
FTP> binary
200 Switching to Binary mode.

      [Choosing a couple of files at random...]

FTP> get 0291-0799-A.PDF
227 Debuging Passive Mode (15,73,208,133,159,62).
150 Opening BINARY mode data connection for 0291-0799-A.PDF (52497 bytes).
226 Transfer complete.
local: SYS$SYSROOT:[SYSMGR]0291-0799-A.PDF;1  remote: 0291-0799-A.PDF
52497 bytes received in 00:00:00.21 seconds (242.98 Kbytes/s)
FTP> get av-rt17c-te.pdf
227 Debuging Passive Mode (15,73,208,133,158,102).
150 Opening BINARY mode data connection for av-rt17c-te.pdf (83962 bytes).
226 Transfer complete.
local: SYS$SYSROOT:[SYSMGR]av-rt17c-te.pdf;1  remote: av-rt17c-te.pdf
83962 bytes received in 00:00:00.35 seconds (229.04 Kbytes/s)
FTP> quit
221 Goodbye.
ITS $ 

> [...] On power on, SA5300 is shown as PYA0, but no disks. SA5300 is
> NOT accessed by SRM. [...]

   "shown"?  I have no experience with an SA5300A, so, as suggested
earlier, "Copy+paste is your friend."  What, exactly, does "NOT accessed
by SRM" mean to you?  As usual, a clear description of what actually did
happen is often more helpful than a vague description of what did NOT
happen.

   The SRM firmware version(s) might be (a) potentially interesting
datum/data.  Knowing nothing, I'd guess that if you see a device name
like "PYA0", then the firmware has at least some idea of what that
device is.  As for how to configure an SA5300A in a useful way, I'd need
to read the documentation (for it and/or the AlphaServer).


Topic author
willemgrooters
Valued Contributor
Posts: 73
Joined: Fri Jul 12, 2019 1:59 pm
Reputation: 0
Location: Netherlands
Status: Offline
Contact:

Re: Looking for manuals for SA5300A

Post by willemgrooters » Thu Jan 27, 2022 11:22 am

Using FileZilla, set to passive.

Status: Resolving address of ftp.hp.com
Status: Connecting to 15.73.48.53:21...
Status: Connection established, waiting for welcome message...
Status: Insecure server, it does not support FTP over TLS.
Status: Logged in
Status: Retrieving directory listing...
Status: Directory listing of "/" successful
Status: Disconnected from server
Status: Resolving address of ftp.hp.com
Status: Connecting to 15.73.48.53:21...
Status: Connection established, waiting for welcome message...
Status: Insecure server, it does not support FTP over TLS.
Status: Logged in
Status: Retrieving directory listing...
Status: Directory listing of "/" successful
Status: Retrieving directory listing of "/pub"...
Status: Calculating timezone offset of server...
Status: Timezone offset of server is 0 seconds.
Status: Directory listing of "/pub" successful
Status: Retrieving directory listing of "/pub/alphaserver"...
Status: Directory listing of "/pub/alphaserver" successful
Status: Retrieving directory listing of "/pub/alphaserver/storage"...
Status: Directory listing of "/pub/alphaserver/storage" successful
Status: Retrieving directory listing of "/pub/alphaserver/storage/controllers"...
Status: Directory listing of "/pub/alphaserver/storage/controllers" successful
Status: Retrieving directory listing of "/pub/alphaserver/storage/controllers/sa5300a"...
Status: Directory listing of "/pub/alphaserver/storage/controllers/sa5300a" successful

Then downloading the documents - no matter how many:

Status: Resolving address of ftp.hp.com
Status: Connecting to 15.72.239.76:21...
Status: Resolving address of ftp.hp.com
Status: Connecting to 15.72.239.76:21...
Status: Connection established, waiting for welcome message...
Status: Connection established, waiting for welcome message...
Error: Connection closed by server
Error: Could not connect to server
Error: Connection closed by server
Error: Could not connect to server
Status: Disconnected from server
Status: Disconnected from server
Status: Delaying connection for 5 seconds due to previously failed connection attempt...
Status: Delaying connection for 5 seconds due to previously failed connection attempt...

and so on...

On VMS (aftre this):

$ ftp
FTP> open ftp.hp.com
421 Service not available, Remote server has closed the connection
FTP> Exit
$ ftp ftp.hp.com
421 Service not available, Remote server has closed the connection
$

Will try later....


sms
Active Contributor
Posts: 49
Joined: Fri Aug 21, 2020 5:18 pm
Reputation: 0
Status: Offline

Re: Looking for manuals for SA5300A

Post by sms » Thu Jan 27, 2022 5:55 pm

Code: Select all

> Using FileZilla, set to passive.

   I don't see "passive" mentioned anyplace (but that might be normal).

   I don't use FileZilla much (I had a years-old version 3.32.0 on my
Mac), so I know nothing, but a new one (3.57.0) worked (mostly) for me:

Resolving address of ftp.hp.com
Status:         Connecting to 15.72.188.125:21...
Status:         Connection attempt failed with "ECONNREFUSED - Connection refused by server", trying next address.
Status:         Connecting to 15.73.48.54:21...
Status:         Connection established, waiting for welcome message...
Status:         Insecure server, it does not support FTP over TLS.
Status:         Logged in
Status:         Retrieving directory listing...
Status:         Directory listing of "/" successful
Status:         Retrieving directory listing of "/pub"...
Status:         Calculating timezone offset of server...
Status:         Timezone offset of server is 0 seconds.
Status:         Directory listing of "/pub" successful
Status:         Retrieving directory listing of "/pub/alphaserver"...
Status:         Directory listing of "/pub/alphaserver" successful
Status:         Retrieving directory listing of "/pub/alphaserver/storage"...
Status:         Directory listing of "/pub/alphaserver/storage" successful
Status:         Retrieving directory listing of "/pub/alphaserver/storage/controllers"...
Status:         Directory listing of "/pub/alphaserver/storage/controllers" successful
Status:         Retrieving directory listing of "/pub/alphaserver/storage/controllers/sa5300a"...
Status:         Directory listing of "/pub/alphaserver/storage/controllers/sa5300a" successful
Status:         Resolving address of ftp.hp.com
Status:         Connecting to 15.72.188.125:21...
Status:         Connection attempt failed with "ECONNREFUSED - Connection refused by server", trying next address.
Status:         Connecting to 15.73.48.54:21...
Status:         Connection established, waiting for welcome message...
Status:         Insecure server, it does not support FTP over TLS.
Status:         Logged in
Status:         Starting download of /pub/alphaserver/storage/controllers/sa5300a/av-rt17a-te.pdf
Status:         File transfer successful, transferred 179,392 bytes in 1 second
Status:         Disconnected from server
Status:         Connection closed by server


> $ ftp
> FTP> open ftp.hp.com
> 421 Service not available, Remote server has closed the connection

   As I showed, it works here.  Try it at a friend's house?  To me, this
looks more like a problem with your network/connection than with the FTP
server.  (Too many NAT routers cascaded?)  A "debug" command in the FTP
client program might be interesting.


Topic author
willemgrooters
Valued Contributor
Posts: 73
Joined: Fri Jul 12, 2019 1:59 pm
Reputation: 0
Location: Netherlands
Status: Offline
Contact:

Re: Looking for manuals for SA5300A

Post by willemgrooters » Fri Jan 28, 2022 9:40 am

Retry on VMS:

$ ftp ftp.hp.com
220 (vsFTPd 3.0.2)
Connected to g4t7986.houston.hp.com.
Name (g4t7986.houston.hp.com:system): anonymous
331 Please specify the password.
Password:
230 Login successful.
FTP> passive all
Passive is ALL.
FTP> cd pub
250 Directory successfully changed.
FTP> cd alphaserver
250 Directory successfully changed.
FTP> cd storage
250 Directory successfully changed.
FTP> cd controllers/sa5300a
250 Directory successfully changed.
FTP> ls
227 Debuging Passive Mode (15,72,188,128,157,215).
150 Here comes the directory listing.
0291-0799-A.PDF
0292-0799-A.PDF
13JE-1000A.PDF
239449-009.PDF
ACUXE126.EXE
ACUXE_V0640_11P08_1.EXE
AV-RT16F-TE.PDF
AV-RT17D-TE.PDF
CPQACUXE13071A.TAR
EK-SA530-INE01.PDF
KZPDC288.zip
KZPDC340.zip
OVMS-ACU-XE.zip
TC020604TB.PDF
TRU64-ACU-XE.zip
acu-xe-userguide.pdf
adfu_v1_10a.zip
av-rt16b-te.pdf
av-rt16c-te.pdf
av-rt16d-te.pdf
av-rt16e-te-192268-003.pdf
av-rt17a-te.pdf
av-rt17b-te.pdf
av-rt17c-te.pdf
ek-sa530-in-b01.pdf
ek-sa530-in-c01.pdf
ek-sa530-in-d01.pdf
hp-axpvms-acuxe-v0640-11p08-1.zip
kzpdc294.bin
sa5300a_rmf2.pdf

226 Directory send OK.
557 bytes received in 00:00:00.01 seconds (46.42 Kbytes/s)
FTP> mget *
227 Debuging Passive Mode (15,72,188,128,156,222).
150 Opening BINARY mode data connection for 0291-0799-A.PDF (52497 bytes).
226 Transfer complete.
local: DATADISK3:[000000.sa5300]0291-0799-A.PDF;2 remote: 0291-0799-A.PDF
52488 bytes received in 00:00:00.36 seconds (139.60 Kbytes/s)
227 Debuging Passive Mode (15,72,188,128,156,180).
150 Opening BINARY mode data connection for 0292-0799-A.PDF (47043 bytes).
226 Transfer complete.
local: DATADISK3:[000000.sa5300]0292-0799-A.PDF;2 remote: 0292-0799-A.PDF
47034 bytes received in 00:00:00.25 seconds (183.02 Kbytes/s)
227 Debuging Passive Mode (15,72,188,128,156,137).
150 Opening BINARY mode data connection for 13JE-1000A.PDF (43926 bytes).
226 Transfer complete.
local: DATADISK3:[000000.sa5300]13JE-1000A.PDF;2 remote: 13JE-1000A.PDF
43807 bytes received in 00:00:00.25 seconds (170.47 Kbytes/s)
227 Debuging Passive Mode (15,72,188,128,156,166).
150 Opening BINARY mode data connection for 239449-009.PDF (1527139 bytes).
%TCPIP-E-FTP_OUTPROCF, error processing output file DATADISK3:[000000.sa5300]239449-009.PDF;2
-RMS-W-RTB, 59509 byte record too large for user's buffer

after a minute or so, all the rest fails:

421 Service not available, Remote server has closed the connection
%TCPIP-E-FTP_NETERR, I/O error on network device
-SYSTEM-F-IVCHAN, invalid I/O channel

and so on.

Next time, ls, get .... are blocked. Disconnected and re-started from scratch:

$ ftp ftp.hp.com
220 (vsFTPd 3.0.2)
Connected to g2t4711.austin.hp.com.
Name (g2t4711.austin.hp.com:system): anonymous
331 Please specify the password.
Password:
230 Login successful.
FTP> passive all
Passive is ALL.
FTP> cd pub/alphaserver/storage/controllers/sa5300a
250 Directory successfully changed.
FTP> ls
227 Debuging Passive Mode (15,73,208,136,157,115).
150 Here comes the directory listing.
0291-0799-A.PDF
0292-0799-A.PDF
13JE-1000A.PDF
239449-009.PDF
ACUXE126.EXE
ACUXE_V0640_11P08_1.EXE
AV-RT16F-TE.PDF
AV-RT17D-TE.PDF
CPQACUXE13071A.TAR
EK-SA530-INE01.PDF
KZPDC288.zip
KZPDC340.zip
OVMS-ACU-XE.zip
TC020604TB.PDF
TRU64-ACU-XE.zip
acu-xe-userguide.pdf
adfu_v1_10a.zip
av-rt16b-te.pdf
av-rt16c-te.pdf
av-rt16d-te.pdf
av-rt16e-te-192268-003.pdf
av-rt17a-te.pdf
av-rt17b-te.pdf
av-rt17c-te.pdf
ek-sa530-in-b01.pdf
ek-sa530-in-c01.pdf
ek-sa530-in-d01.pdf
hp-axpvms-acuxe-v0640-11p08-1.zip
kzpdc294.bin
sa5300a_rmf2.pdf

226 Directory send OK.
557 bytes received in 00:00:00.01 seconds (39.79 Kbytes/s)
FTP> get ACUXE126.EXE
227 Debuging Passive Mode (15,73,208,136,156,184).
150 Opening BINARY mode data connection for ACUXE126.EXE (3563523 bytes).
%TCPIP-E-FTP_OUTPROCF, error processing output file DATADISK3:[000000.sa5300]ACUXE126.EXE;1
-RMS-W-RTB, 61440 byte record too large for user's buffer

and after some time (1 minute or so):

421 Service not available, Remote server has closed the connection

After that, using Filezilla (checked passive was set....), then was able to download the files (one by one).


sms
Active Contributor
Posts: 49
Joined: Fri Aug 21, 2020 5:18 pm
Reputation: 0
Status: Offline

Re: Looking for manuals for SA5300A

Post by sms » Fri Jan 28, 2022 6:47 pm

Code: Select all

> Retry on VMS:

      tcpip show version

> FTP> passive all

   Why "all"?  I know nothing, but around here:

ITS $ tcpip show version

  HP TCP/IP Services for OpenVMS Industry Standard 64 Version V5.7 - ECO 5
  on an HP rx2600  (1.50GHz/6.0MB) running OpenVMS V8.4-2L3

FTP> help set passive parameters

SET

  PASSIVE

    Parameters

      keyword

         The FTP client program starts with the value AUTO. All keyword
         comparisons are done without regard for typographical case (case-
         blind).

         o  ALL

            Does nothing.
[...]

   Doesn't sound (to me) as useful as "ON".

> 150 Opening BINARY mode data connection for 239449-009.PDF (1527139 bytes).
> %TCPIP-E-FTP_OUTPROCF, error processing output file DATADISK3:[000000.sa5300]239449-009.PDF;2
> -RMS-W-RTB, 59509 byte record too large for user's buffer

   ";2"?  Is there an existing ";1" with different attributes?  (Perhaps
the result of a previous ASCII transfer?)

> 150 Opening BINARY mode data connection for ACUXE126.EXE (3563523 bytes).

   I know that it's saying "BINARY", but did you ever specify "binary"
(SET TYPE BINARY)?

> After that, using Filezilla (checked passive was set....), then was
> able to download the files (one by one).

   I'd expect that you could select multiple files in the FileZilla
interface, and drag/transfer them all in one operation.


Topic author
willemgrooters
Valued Contributor
Posts: 73
Joined: Fri Jul 12, 2019 1:59 pm
Reputation: 0
Location: Netherlands
Status: Offline
Contact:

Re: Looking for manuals for SA5300A

Post by willemgrooters » Wed Feb 02, 2022 3:54 pm

sms wrote:
Fri Jan 28, 2022 6:47 pm

Code: Select all

> FTP> passive all

   Why "all"?  I know nothing, but around here:

ITS $ tcpip show version

  HP TCP/IP Services for OpenVMS Industry Standard 64 Version V5.7 - ECO 5
  on an HP rx2600  (1.50GHz/6.0MB) running OpenVMS V8.4-2L3

$ tcpip sho ver

HP TCP/IP Services for OpenVMS Alpha Version V5.7 - ECO 5
on an AlphaStation DS10 617 MHz running OpenVMS V8.4-2L1

$

Why not ALL? there seem to be different options for IP4 and IP6; And it did work :)
sms wrote:
Fri Jan 28, 2022 6:47 pm

Code: Select all

> 150 Opening BINARY mode data connection for 239449-009.PDF (1527139 bytes).
> %TCPIP-E-FTP_OUTPROCF, error processing output file DATADISK3:[000000.sa5300]239449-009.PDF;2
> -RMS-W-RTB, 59509 byte record too large for user's buffer

   ";2"?  Is there an existing ";1" with different attributes?  (Perhaps
the result of a previous ASCII transfer?)

The previous result gave the same error; I didn't remove the file, so ;2
sms wrote:
Fri Jan 28, 2022 6:47 pm

Code: Select all


> 150 Opening BINARY mode data connection for ACUXE126.EXE (3563523 bytes).

   I know that it's saying "BINARY", but did you ever specify "binary"
(SET TYPE BINARY)?
I did.

Post Reply