Vgit on OpenVMS AXP 8.4-2L1

Talk about commercial or opensource products that already exist for OpenVMS or may be available in the future.
Post Reply

Topic author
joukj
Contributor
Posts: 12
Joined: Thu Aug 27, 2020 5:50 am
Reputation: 0
Status: Offline

Vgit on OpenVMS AXP 8.4-2L1

Post by joukj » Wed Dec 15, 2021 5:18 am

Hi,

I have problems running vgit v1.x on OpenVMS AXP 8.4-2L1. version 0.9x works. The problem seems to be the CRTL which is too old on my system. (For IA64 I found the patch files with the OpenJDK distribution)

Question : are the nescessary patches available for hobyist systems?

regards
Jouk


marty.stu
Site Admin
Valued Contributor
Posts: 55
Joined: Tue May 21, 2019 6:56 am
Reputation: 0
Status: Offline

Re: Vgit on OpenVMS AXP 8.4-2L1

Post by marty.stu » Wed Dec 15, 2021 7:48 am

Hi Jouk,

Only some security patches are currently available for community use. We will discuss adding CRTL updates to the commmunity program, at least for Alpha, as no major updates are currently planned for OpenVMS for Alpha.

Kind regards,

Maxim Megalinskiy
VSI Training Team
Run to the bedroom, In the suitcase on the left You'll find my favorite axe.


marty.stu
Site Admin
Valued Contributor
Posts: 55
Joined: Tue May 21, 2019 6:56 am
Reputation: 0
Status: Offline

Re: Vgit on OpenVMS AXP 8.4-2L1

Post by marty.stu » Thu Feb 24, 2022 9:05 am

Hi Jouk,

We have discussed making the CRTL-related ecokits for V8.4-2L1 available for community use, and everything required to install the latest version of CRTL on 2L1 was uploaded to the server:

Code: Select all

sftp> ls
ALPHA0842L.HASH                  ALPHA0842L1.ZIP                  ALPHA0842L1.ZIPEXE               ALPHA0842L1DOC.HASH              ALPHA0842L1DOC.ZIP               ALPHA0842L1DOC.ZIPEXE            ALPHA0842L1DOC_ZIP.HASH
ALPHA0842L1_ZIP.HASH             AVMS842L1DOC.HASH                AVMS842L1DOC.ZIP                 AVMS842L1DOC.ZIPEXE              AVMS842L1DOC_ZIP.HASH            LPS.DIR                          VMS842L1A_DPML-V0100.TXT
VMS842L1A_DPML-V0100.ZIPEXE      VMS842L1A_DPML-V0100.ZIPEXE_VNC  VMS842L1A_RTL-V0300.TXT          VMS842L1A_RTL-V0300.ZIPEXE       VMS842L1A_RTL-V0300.ZIPEXE_VNC
So please check if VGIT works for you with these patches installed.

Thank you,

Maxim Megalinskiy
VSI Community License Team
Run to the bedroom, In the suitcase on the left You'll find my favorite axe.


Topic author
joukj
Contributor
Posts: 12
Joined: Thu Aug 27, 2020 5:50 am
Reputation: 0
Status: Offline

Re: Vgit on OpenVMS AXP 8.4-2L1

Post by joukj » Thu Jun 09, 2022 7:04 am

Still a kit is missing

The following products will be installed to destinations:
VSI AXPVMS VMS842L1A_DPML V1.0 DISK$ALPHASYS:[VMS$COMMON.]
VSI AXPVMS VMS842L1A_RTL V3.0 DISK$ALPHASYS:[VMS$COMMON.]

%VSIKIT-F-NOPREREQ, Required prerequisite patch kit not installed

------------------------------------------------------------------------
This patch kit requires a previous kit for VSI OpenVMS V8.4-2L1

Please install the VMS842L1A_NOTARY-V0200 patch kit before
installing this kit.
------------------------------------------------------------------------

Portion done: 0%

Recovery pass starting ...


Recovery pass concluded


Jouk


madsweeney
VSI Expert
Active Contributor
Posts: 32
Joined: Mon Jun 10, 2019 9:23 am
Reputation: 0
Status: Offline

Re: Vgit on OpenVMS AXP 8.4-2L1

Post by madsweeney » Thu Jun 09, 2022 8:34 am

There are new Alpha RTL and DPML kits that were very recently released. We will update the Alpha Community download folder with the new RTL, DPML and the Notary kits.
Dave "Mad" Sweeney
Chief Customer Advocate
VMS Software, Inc.
Burlington, MA 01803
USA


Topic author
joukj
Contributor
Posts: 12
Joined: Thu Aug 27, 2020 5:50 am
Reputation: 0
Status: Offline

Re: Vgit on OpenVMS AXP 8.4-2L1

Post by joukj » Thu Jun 09, 2022 9:12 am

Thanks
Jouk


madsweeney
VSI Expert
Active Contributor
Posts: 32
Joined: Mon Jun 10, 2019 9:23 am
Reputation: 0
Status: Offline

Re: Vgit on OpenVMS AXP 8.4-2L1

Post by madsweeney » Thu Jun 09, 2022 2:38 pm

The Alpha Community Media folder is updated with the Notary 2.0, DPML 2.0 and RTL 5.0 kits. Please download the Notary kit, install the kit and verify vgit works.

Added in 10 minutes 16 seconds:
The Integrity Community download folder is also updated with the Notary V2.0. DPML 2.0 and RTL V5.0 kits. Remember these kits are for your personal use only and cannot be shared with anyone else or any company.
Dave "Mad" Sweeney
Chief Customer Advocate
VMS Software, Inc.
Burlington, MA 01803
USA


Topic author
joukj
Contributor
Posts: 12
Joined: Thu Aug 27, 2020 5:50 am
Reputation: 0
Status: Offline

Re: Vgit on OpenVMS AXP 8.4-2L1

Post by joukj » Fri Jun 10, 2022 4:04 am

Thanks
vgit now works on my Alpha

Post Reply