No IP cluster - or is it?

OpenVMS clustering, cluster management utilities, protocols, building and managing clusters of any scale.
Post Reply

Topic author
Valued Contributor
Posts: 88
Joined: Fri Jul 12, 2019 1:59 pm
Reputation: 0
Location: Netherlands
Status: Offline

No IP cluster - or is it?

Post by willemgrooters » Mon Sep 13, 2021 7:08 am

Years ago I wanted to give it a try with clustering over IP, so I set up set an environment (1 real system, one emulator) to cluster over IP, but due to network issues (aside from VMS) it was abandoned.
Now I used the emulated system to set up VSI-based VMS to test the installation on my live system, chose "PRESERVE" to keep all of the system intact. However, I had to reinstall TCPIP (just telnet, NTP and FTP) and clustering.
TCPIP is no real issue on this system, but I ran into problems with clustering.

Ran cluster$config_lan to form a cluster: Had to re-enter cluster ID and password (Luckily I remembered them from my origial (live) system...) and said NO clustering over IP.
Rebooted: The instance tried to create a cluster - OVER IP - Which I had stated NOT to. Since there is no system that will answer, it failed to boot.
Booted interactively, removed cluster settings. System comes up nicely.
Run cluster$config_lan again, reboot to full extent: Same problem.

Code: Select all

$ dir sys$system:*ip*.dat/siz


PE$IP_CONFIG.DAT;1         1

Total of 2 files, 2 blocks.
These files contain information about IP cluster configuration. Removed them: problem solved: System will now come up as a cluster member

Post Reply