Page 1 of 1

Student Package issues

Posted: Sun May 17, 2020 12:23 am
by stk
I have some issues with the Student Package that prevent me changing anything in the Configuration Utility.

(1) When I try to add a network interface the NICs (3 of them) on the system seem to be displayed but the dropdown says "Invalid adapter" whatever I choose.
(2) I cannot save any changes I make anyway because (a) I get an error about the log file not being a valid path, and then (b) if I manage to fix that I get an error about an NVRAM file being an invalid path and I don't see how I can fix that.
(3) If I try and copy the contents of "C:\Program Files\OpenVMS" to another disk and change the first drive in the config to point to the new location (a) the drive type changes, and (b) if I try and run the config from within the utility (because I cannot save it) the file cannot be found.

I'm running on Win7 Pro and out of the box Student Package boots and otherwise works.

Any help appreciated.

Edit: I've tried under Windows 10 Pro as well. Cannot set the NIC and same file errors if I try to Save in the Configuration Utility.

Re: Student Package issues

Posted: Mon May 18, 2020 10:32 am
by marty.stu
Hi stk,

Regarding the first issue - have you tried to to install an official version of FreeAXP on top of the student package? We recommend that you follow the steps described in this guide.

The second issue should be fixed by saving the configuration file to a directory with full access permissions. In other words, you should not save the config to the system directories, including Program Files.

As for the third issue, we need more details to reproduce the steps you follow. Anyway, generally you don't need to move the file manually, as you can specify a path to the image file upon installation.

In general, we recommend that you create a new configuration file from scratch by pressing the New Configuration File button in the configuration utility and specifying the paths manually. When you are done with the setup, open the File menu, select Save Configuration File as, specify the path that doesn't contain any special characters and provides full access permissions to the current user, and then press Run configuration file.

Kind regards,

Maxim Megalinskiy
VSI Training Team

Re: Student Package issues

Posted: Mon May 18, 2020 9:19 pm
by stk

(1) I ran the Configuration Utility as Administrator so permissions should not have been a problem.
(2) The installation process does not allow me to select an alternative location. The Browse button is greyed out and the text box for the location will not accept input. This is running the install as Administrator.

Is it worth downloading again?

BTW, the systems are members of a Windows Domain...would that change expected behavior?


Edit: The instructions in your YouTube link (the written ones, I haven't watched the video, I assume it reflects the written instructions), the instructions on the Hobbyist page ( ) and the instructions in the PDF in the kit are all different in a variety of ways. For example, the Hobbyist page says you have to manually install PCAP, no mention of that in other instructions...

So what are the definitive instructions????

The latest downloadable kit is dated march 2020, your video predates that.

Re: Student Package issues

Posted: Tue May 19, 2020 9:48 am
by marty.stu

Thank you for providing a more detailed answer. Let me describe the steps that I performed to install the kit and then I'll try to answer your questions.

1. I downloaded the latest version of the kit from the VSI FTP storage.
2. I initialized installation and specified the path to the image file from the distribution menu:
3. I waited for the installation process to complete and unchecked Start the application at the end of the process.
4. I opened the configuration utility and found out that the network adapter was broken:
5. I went to the Migration Specialties website and downloaded the latest version of the kit: ... p_646b.exe. It is needed to install or fix the MSI PCAP driver that is bundled with the package.
6. I had to move the disk image away from the folder so that the FreeAXP installer doesn't automatically remove it, initialized installation, and agreed to uninstall the old version and replace it with a newer one. After the installation was complete, I moved the image back to the folder in which it was stored, ran the utility again, pressed the New configuration file button, went to the pci11 tab, and the adapter appeared in the list:
6. I unchecked the logfile, went to the pci6 tab, and specified the image file installed with the student kit as disk 0.0, saved the config file to a separate folder, and ran emulation:
Now back to your questions:
BTW, the systems are members of a Windows Domain...would that change expected behavior?
Not sure, as my work PC is a member of a domain as well, but it could be depending on the policies applied. Unfortunately, we are unable to fully test all possible scenarios, but as the issues you describe are apparently related to access permissions, I tend to say that that's the reason of the issues with saving the config file and NVRAM.

The differences between the video guide and the current state of the kit are related to the fact that the video was recorded almost a year ago and there were some minor changes implemented to the kit and the emulator since then, but none of them is grave enough to change the procedure. Still, I recommend you to use the video guide as it is more detailed.

Hope this helps.


Re: Student Package issues

Posted: Wed May 20, 2020 6:13 am
by stk
Hi Maxim,

That sort of helps.

I now understand why the location box was disabled. I assumed it applied to the entire package...specify one base location for everything rather than specifying the location on a component by component basis. I never selected an individual component. My bad. Not behaviour I expected.

As for the rest. Well installing/uninstalling the various bits seems to leave some sort of remnant history in the system so the behaviour I observed did not match yours. But I now have a config file that seems to work even though I have to (currently) (a) start it from the Configuration utility, (b) choose between Avanti and FreeAXP, and (c) explicitely boot DKA0. The system disk is also not on the C: drive so sort of where I wanted to be.

Thanks for everything.


Re: Student Package issues

Posted: Fri Jun 05, 2020 3:42 am
by martinv
Following Maxim's guidelines, I got it up and running. Thanks a lot for the detailed instructions!
Some things I still stumbled over:
  • In the enterprise environment I'm working in, I have to start the configuration utility - and from there, the emulator - using an administrative account. Otherwise, I guess, it won't be able to properly access the network interfaces (and show "invalid adapter").
  • When intending to use the original config file, load it into a text editor before using it with the config utility, and extend all occurences of "OpenVMS Student Package" filenames to a full path specification.
  • When moving the OpenVMS directory, DO NOT have special characters in the path; the config utility won't save the file ("invalid path ... <scrambled umlaut>..."). <sigh>
@Andrew, Re the "choose between Avanti and FreeAXP" bit: I've seen that behaviour, too, but using the latest FreeAXP/Avanti version the installer is smart enough to recognize the older version coming from the student package and uninstalls it.