OpenVMS V9.1 FT on VMware Workstation 16 Player

Having difficulties when installing the system? Your system runs slowly and requires some tweaking? You can get help here.
Post Reply
User avatar

Topic author
imiller
Contributor
Posts: 15
Joined: Fri Jun 28, 2019 8:45 am
Reputation: 0
Location: Reading, UK
Status: Offline
Contact:

OpenVMS V9.1 FT on VMware Workstation 16 Player

Post by imiller » Tue Jul 20, 2021 1:02 pm

I'm having trouble configuring a virtual machine on VMware Workstation 16 Player. Currently it just crashes booting from the installation ISO image.

Anyone got any pointers?
Ian Miller
[ personal opinion only. usual disclaimers apply. Do not taunt happy fun ball ].


madsweeney
VSI Expert
Contributor
Posts: 22
Joined: Mon Jun 10, 2019 9:23 am
Reputation: 0
Status: Offline

Re: OpenVMS V9.1 FT on VMware Workstation 16 Player

Post by madsweeney » Tue Jul 20, 2021 5:10 pm

Hello Ian,

Here is a writeup done by VSI R&D on setting up V9.1 on VMware Workstation.

==================================
1. Click Create a New Virtual Machine to start Wizard
2. Click O "I will install the Operating System Later" and Next
3. Check O for "Other", for Version, select "Other 64-bit" (this is important!) and Next
4. Define Virtual machine name as "V91", and click next
5. Set Maximum disk size to 2.0GB or more, click Next
6. Click Finish
7. Click on V91 VM and then click Edit virtual machine setting
8. Click Hard Disk(IDE) and Remove!
9. Click Add... and select Hard Disk and Next
10. Select SATA and Next
11. Click O for Create a new virtual disk
12. Set maximum disk size to 2.0GB or more, click Next
13. Select CD/DVD and Advanced button
14. Select Virtual device node as SATA
15. From pull down, select "SATA 0:1 CD/DVD (SATA)" and the OK
16. Click O to Use ISO image file and point to V91_KIT.ISO file on local system and click OK
17. Click Memory and set to 8Gb or more and click OK
18. Close VMware Player!
19. Open Notepad and navigate to Documents\Virtual Machine\V91
20. Select All File (*.*)
21. Open V91.vmx file
22. After virtualHW.version, add the following 4 lines


firmware = "efi"
serial0.present = "TRUE"
serial0.fileType = "network"
serial0.fileName = "telnet://:2023"
1. Save file
2. Close Notepad
3. Open VMware Player and select V91 VM
4. Select Play virtual machine
5. Wait 1-2 minutes until blue UEFI screen appears
6. Click mouse on blue screen to enable input focus
7. Hit down arrow key to EFI Internal Shell and hit return
8. Shell> fs0:
9. fs0:> cd efi\vms
10. fs0:\EFI\VMS> vms_bootmgr
11. Even though directed on the screen, do not connect serial port. It will not work.
12. BOOTMGR> BOOT DKA100
13. Wait about 2 minutes to boot to "Use a Terminal Utility" message to be displayed
14. Hold down left CTRL and hit left Alt to get input focus back to local system
15. Setup Putty session as described elsewhere
16. Open Putty window to serial line
17. There may be garbage characters left of the screen but hit enter a few times and VMS installation menu should appear.
18. Note that DKA100 is DVD kit disk and DKA0 is blank disk for installation
19. Perforn VMS installation and shutdown after installation is completed
20. When system reboots, fs0: will be new system disk and FS1: will be DVD kit disk
21. Shell> fs0:
22. fs0:> cd efi\vms
23. fs0:\EFI\VMS> vms_bootmgr
24. BOOTMGR> BOOT DKA0
25. System will now reboot into AUTOGEN and reboot
26. Boot DKA0 again and login

==================================

Hope this helps.
Dave "Mad" Sweeney
Chief Customer Advocate
VMS Software, Inc.
Burlington, MA 01803
USA

User avatar

Topic author
imiller
Contributor
Posts: 15
Joined: Fri Jun 28, 2019 8:45 am
Reputation: 0
Location: Reading, UK
Status: Offline
Contact:

Re: OpenVMS V9.1 FT on VMware Workstation 16 Player

Post by imiller » Fri Jul 23, 2021 11:52 am

that worked :-)

One minor point. I had to make the VM disk allocate all the space before the INIT command worked.
Ian Miller
[ personal opinion only. usual disclaimers apply. Do not taunt happy fun ball ].


pj3210
Visitor
Posts: 1
Joined: Tue Oct 05, 2021 10:50 am
Reputation: 0
Status: Offline

Re: OpenVMS V9.1 FT on VMware Workstation 16 Player

Post by pj3210 » Tue Oct 05, 2021 11:04 am

I followed all the steps and did not encounter any issue or question, up to second item 7. However I got stuck on item 8:
Shell> fs0:
Entering that command says Shell: Invalid mapping name - 'fs0:' Exit status code: No Mapping.
Before that there is a Device mapping table mentioning two devices:
blk0 :BlockDevice - Alias (null) PCiRoot ... /Sata(0x0)...
blk1 :BlockDevice - Alias (null) PCiRoot ... /Sata(0x1)...

Entering blk0: seems to work but item 9 (cd efi\vms) gives a cd: Target directory not found.
The iso installed for the cd is alpha0842l1.iso.

Anyone has a clue?


marty.stu
Site Admin
Active Contributor
Posts: 42
Joined: Tue May 21, 2019 6:56 am
Reputation: 0
Location: Chelyabinsk
Status: Offline
Contact:

Re: OpenVMS V9.1 FT on VMware Workstation 16 Player

Post by marty.stu » Tue Oct 05, 2021 11:28 am

Hi pj3210,

The guide above is for installing OpenVMS for x86 V9.1 which is a native port to x86. The version you are trying to install is to be used only on Alpha systems which is a completely different architecture. To use it, you either need a physical Alpha server or an emulator, such as FreeAXP or AXPBox.

Kind regards,

Maxim Megalinskiy
VSI Training Team
Run to the bedroom, In the suitcase on the left You'll find my favorite axe.

Post Reply