axpbox installation fails with PFMBSY -> CTRLERR

Having difficulties when installing the system? Your system runs slowly and requires some tweaking? You can get help here.
Post Reply

Topic author
martin
Contributor
Posts: 13
Joined: Tue Mar 22, 2022 6:47 pm
Reputation: 0
Location: England
Status: Offline

axpbox installation fails with PFMBSY -> CTRLERR

Post by martin » Wed Oct 05, 2022 12:03 pm

I've built my axpbox and have been trying to install VMS on it. Each time I try I get as far as:

Code: Select all

Execution phase starting ...

The following products will be installed to destinations:
    VSI AXPVMS AVAIL_MAN_BASE V8.4-2L1     DISK$ALPHASYS:[VMS$COMMON.]
    VSI AXPVMS CDSA V2.4-320A              DISK$ALPHASYS:[VMS$COMMON.]
    VSI AXPVMS DWMOTIF V1.7-F              DISK$ALPHASYS:[VMS$COMMON.]
    VSI AXPVMS DWMOTIF_SUPPORT V8.4-2L1    DISK$ALPHASYS:[VMS$COMMON.]
    VSI AXPVMS HPBINARYCHECKER V1.1-A      DISK$ALPHASYS:[VMS$COMMON.]
    VSI AXPVMS KERBEROS V3.1-152A          DISK$ALPHASYS:[VMS$COMMON.]
    VSI AXPVMS OPENVMS V8.4-2L1            DISK$ALPHASYS:[VMS$COMMON.]
    VSI AXPVMS SSL V1.4-502A               DISK$ALPHASYS:[VMS$COMMON.]
    VSI AXPVMS SSL1 V1.0-2JA               DISK$ALPHASYS:[VMS$COMMON.]
    VSI AXPVMS TCPIP V5.7-13ECO5F          DISK$ALPHASYS:[VMS$COMMON.]
    VSI AXPVMS TDC_RT V2.3-1220            DISK$ALPHASYS:[VMS$COMMON.]
    VSI AXPVMS VMS V8.4-2L1                DISK$ALPHASYS:[VMS$COMMON.]

Portion done: 0%...10%

%PCSI-E-WRITEERR, error writing DISK$ALPHASYS:[VMS$COMMON.][SYSLIB]DECW$OPENGLPEERRI.EXE
;1
-SYSTEM-F-CTRLERR, fatal controller error
-SYSTEM-W-PFMBSY, page fault monitor is in use
%PCSI-E-OPFAILED, operation failed
Terminating is strongly recommended.  Do you want to terminate? [YES]
If I ignore this and attempt to continue the installation fails with major components (like DCL) not working.

Initially I built the `disk.img` file with `$ truncate -s 10G disk.img` as per the instructions in https://github.com/lenticularis39/axpbo ... tion-guide I did wonder if a fragmented file was being created so have tried two other techniques: using `VMmanager` to create the file and most recently using:

Code: Select all

$ dd if=/dev/zero of=disk.img.2 bs=10M count=2048
2048+0 records in
2048+0 records out
21474836480 bytes (21 GB, 20 GiB) copied, 122.937 s, 175 MB/s
however the same error occurs on all attempts regardless of the file building technique.

OS: AlmaLinux 8.6
Disk: Ext3 logical volume on an underlying RAID5 over SATA.
Axpbox: 1.1.0
Retired System Manager VMS/UNIX/Linux. Started on a VAX 11/782 with VMS 3.6.

User avatar

volkerhalle
Valued Contributor
Posts: 69
Joined: Fri Aug 14, 2020 11:31 am
Reputation: 0
Status: Offline

Re: axpbox installation fails with PFMBSY -> CTRLERR

Post by volkerhalle » Wed Oct 05, 2022 1:47 pm

Martin,

please have a look at

https://groups.google.com/g/comp.os.vms/c/1RjOD-d0Iv4

<quote>
That is IDE emulation problem. Try SCSI emulation instead. I successfully
installed OpenVMS Alpha on AXPbox.
</quote>

Volker.


Topic author
martin
Contributor
Posts: 13
Joined: Tue Mar 22, 2022 6:47 pm
Reputation: 0
Location: England
Status: Offline

Re: axpbox installation fails with PFMBSY -> CTRLERR

Post by martin » Wed Oct 05, 2022 3:36 pm

Volker,

Thanks for getting back to me. It's 20:35 here, so I'll give it another go tomorrow and report back.

Regards,
Martin
Retired System Manager VMS/UNIX/Linux. Started on a VAX 11/782 with VMS 3.6.


Topic author
martin
Contributor
Posts: 13
Joined: Tue Mar 22, 2022 6:47 pm
Reputation: 0
Location: England
Status: Offline

Re: axpbox installation fails with PFMBSY -> CTRLERR

Post by martin » Thu Oct 06, 2022 6:59 am

Hi Volker,

As promised I'm reporting back. I did as you suggested and put both the CDROM and disk on a SCSI bus. Installation proceeded but with a couple of error concerning DCLTABLES.EXE and HELPLIB.HLB. Looking on the google group you indicated gave me confidence to ignore the errors, and I now have a working OpenVMS system. Many thanks.

Regards,
Martin
Retired System Manager VMS/UNIX/Linux. Started on a VAX 11/782 with VMS 3.6.

Post Reply